Some Problems about Gem

本文发布时间: 2019-Mar-22
Advanced Software Engineering今天在做高级软件工程作业时,遇到一些问题,如下:在新git clone 一个ruby rails的项目之后,在本地进行bundle install的时,系统报错提示需要“gem install pg -v "0.18.3'”,在根据提示安装之后,依然报错:再次根据报错信息,可以看到是因为少依赖包导致,“You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-dev for building a client-side application.”,所以接下来我们安装少的依赖包,"sudo apt-get install postgresql-server-dev-all",之后,我们再次运行“gem install pg -v "0.18.3'”,可以发现问题不再出现。PS:1.如果继续“bundel install”提示出现其他问题,同样可以采取这种方法,根据报错信息,“sudo apt-get install xxxxx”相应的依赖包2.如果在“sudo apt-get install xxxx”中找不到准que的依赖包,可以通过“sudo apt-cache serach xxxx”来查找具体需要安装的依赖包


(以上内容不代表本站观点。)
---------------------------------
本网站以及域名有仲裁协议。
本網站以及域名有仲裁協議。

2020-Jul-13 01:12am
栏目列表