lighttpd启动不了 libssl.so.4&libcrypto.so.4缺失

本文发布时间: 2019-Mar-22
lighttd的出错日志在 log/out_lighttpd 里,当lighttd启动不了时候,这里文件里会说明原因。今天的报错是 error while loading shared libraries: libssl.so.4这是加载动态库时失败了, 为啥失败呀, 因为没找见动态库。 你的环境下 没有 叫 libssl.so.4 的动态库。解决办法就是 想办法弄一个 。方法1, 在别的机器上拷贝一个过来。 比如机器1的lighttd能起来 , 机器2 的起不来 。 那么机器1上面 肯定是有这个库的, 找到了,然后拷过来就好了, 找的方法 find / -name “libssl.so.4” 拷过来 一般放在 几个 放动态库的地方 /lib , /lib64 , /usr/lib, /usr/lib64 。 这是几个默认放动态库的地方 ,程序都会去这儿找。 别忘了 chmod +x libssl.so.4 设计可执行的权限。方法2, 如果我无法在别的机器上拷贝,或者没找见,或者没有。那就在 yum -y install openssl openssl-devel


(以上内容不代表本站观点。)
---------------------------------
本网站以及域名有仲裁协议。
本網站以及域名有仲裁協議。

2020-Jul-13 01:12am
栏目列表